Sunday, February 26, 2012

Rogue Wine Review: Valle Isarco's Aristos Veltliner

My blogging about wines that I experience in my wine classes has really ground to a halt lately, but last week we tasted a wine that was so startling and delicious that I decided to dust off the old fingers and get typing.

The wine is La Cantina Valle Isarco's Aristos Veltliner (2008), from the Alto-Adige region of Italy.  This was my first time tasting veltliner; this variety of grape is not commonly grown anywhere outside of northern Italy and Austria it seems.  This dry white wine had the most amazing bouquet, in part because it had a strong aroma of smoked meat - full-on polish kielbasa to be exact - and I have never smelled meat in a white wine before (though it's common enough in certain red varietals).  In addition to the meaty aroma, the nose had a touch of yoghurt and pears (not pear ester, but fresh pear), as well as some vanilla and savoury herbs.

The palate had flavours of toasty nuts, vanilla bean, apples, pink grapefruit, white pepper, and savoury herbs again.  It was delicious.  This was definitely a fuller-bodied white wine, without being sweet or oily on the palate.  A upper-mid-level acidity gave it great structure and balanced the rather-high alcohol (13.5%).  It had a great finish of apple oatmeal.  Num num num!

I'm going to try to get my hands on this again.  I'm much more of a red-wine person, so when I find these great whites I'm almost more eager to get them and try them a second time.  The LCBO is telling me this bottle doesn't exist in its stores (which clearly isn't true since we're all obligated to purchase everything through the province's monolithic alcohol control agency) but WineAlign is telling me it's $29.  Not bad for such a tasty and unique wine.

2 comments:

  1. I'd like to follow your blog more closely but the color combination of background and print makes it really difficult to read - they are similar hues and wash each other out. just thought I'd note that

    love Alto Adige!

    ReplyDelete
  2. yes, it was my browser...sorry

    works now

    ReplyDelete